
 

 

 

 
 
 
 
 
 
 
 
 
 

 
 

S32K SDK ISELED BETA 3.9.0 Driver 
Installation Guide 

 

NXP Semiconductors Document Number: S32KSDKISELEDRTMUG 

User Guide Rev. 1 , 09/2019 



 

S32K SDK ISELED BETA 3.9.0 Driver Installation Guide, Rev. 1, 09/2019 

2  NXP Semiconductors 

   

Contents 

1. INTRODUCTION .............................................................................................................................................................. 3 

2. DOWNLOADING THE S32 DESIGN STUDIO IDE ....................................................................................................... 3 

3. UPDATING THE S32 SOFTWARE DEVELOPMENT KIT ........................................................................................... 8 

4. INSTALLATION OF S32K SDK ISELED DRIVER ..................................................................................................... 12 

5. TROUBLESHOOTING ................................................................................................................................................... 21 

2. STARTING FROM S32K SDK ISELED EXAMPLE APPLICATION ......................................................................... 24 

 



 

S32K SDK ISELED BETA 3.9.0 Driver Installation Guide, Rev. 1, 09/2019 

3  NXP Semiconductors 

 

1. Introduction 

This user guide describes in detail the steps to install the necessary components to build the customer 

application using the NXP S32K SDK ISELED BETA 3.9.0 driver. 

The S32 Software Development Kit (S32 SDK) is part of the S32 Design Studio (S32DS), representing 

the tool suite for developing of user applications for NXP Automotive and Ultra-Reliable 

microcontrollers. S32K SDK ISELED driver is not integrated as part of standard S32SDK installation, 

thus a few steps need to be done to download and integrate the S32SDK ISELED driver into the 

application. 

The 3 software packages that need to be installed are: S32 Design Studio, S32 SDK and SDK ISELED 

Driver. 

2. Downloading the S32 Design Studio IDE 

The S32 Design Studio IDE is a complimentary integrated development environment for Automotive 

and Ultra-Reliable Arm based MCUs that enables editing, compiling and debugging of applications. 

Based on, open-source software including Eclipse IDE, GNU Compiler Collection (GCC) and GNU 

Debugger (GDB), the S32 Design Studio IDE offers designers a straightforward development tool with 

no code-size limitations. NXP software, along with the S32 Design Studio IDE provide a comprehensive 

enablement environment that reduces development time. 

NOTE 

Despite this document might refer to particular revision of NXP SW, it is 

highly recommended to use the latest available versions of the SW. Those 

versions might not be listed in the screenshots presented in this document 

at the time of creation. 

The screenshots are example screenshot from RTM 3.0.0 release 

In order to download the S32 Design Studio IDE, please follow these steps: 

 
1. Visit the www.nxp.com/S32K-ISELED  
2. Click Get Started Tab and Choose Evaluation Path for Non-AUTOSAR 

 
 

http://www.nxp.com/S32K-ISELED
http://nww.preview.nxp.com/document/guide/get-started-with-the-s32k-iseled:GS-S32K-ISELED
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3. Download Design Studio for ARM 2018.R1 (or newer) for ARM® based MCUs: 

 
 

Alternatively, download link could also be found via www.nxp.com/S32K-ISELED Documents and 

Software Tab. 

 
 
 

4. To proceed with the download, the user needs to be logged-in using the user account. In case of 

new user, please proceed with the Register Now option prior logging into the NXP web page. 

http://www.nxp.com/S32K-ISELED
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5. Download the installation package of S32 Design Studio by selecting appropriate version, based 

on the operation system on your PC. After download, follow the instruction of the Installation 

shield to proceed. 

 

 

6. During the installation of the S32 Design Studio IDE, an Activation code and the license file 

need to be stored on your computer. 
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After successfully installing S32 Design Studio it’s necessary to update the S32 Software Development 

Kit (S32SDK), which comes pre-installed with the S32 Design Studio. To proceed, please follow the 

instructions in next chapter. 

NOTE 

If you already have the S32 Design Studio installed on your computer, 

please make sure you update your installation, prior proceeding to next 

chapter. 
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3. Updating the S32 Software Development Kit 

The S32 Software Development Kit (S32 SDK) is an extensive suite of robust hardware interface and 

hardware abstraction layers, peripheral drivers, RTOS, stacks, and middleware designed to simplify and 

accelerate application development on NXP S32K microcontrollers. As the S32K SDK ISELED driver 

was tested with S32K SDK RTM 3.0.0, the following steps need to be proceed in order to update to 

S32K SDK RTM 3.0.0: 

1. Run the S32K Design studio 

2. Select Help->Install New Software 
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3. Select the server for download of the new packages 

https://www.nxp.com/lgfiles/updates/Eclipse/S32DS_ARM_2018.R1/updatesite 

 
 

4. Click on Select All and then on Next 

 
 

5. Click on Next 

 

https://www.nxp.com/lgfiles/updates/Eclipse/S32DS_ARM_2018.R1/updatesite
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NOTE 

The list of available packages may differ as new support is added. Please 

select all S32SDK S32K1xx RTM_3.0.0 related packages in the list 

above.  
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6. Accept the license agreement and click on Finish

 

 
 

7. Wait for installation finish. Once the updates are installed, please proceed to the next stage, 

download and installation of the S32K SDK ISELED driver, described in next section. 
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4. Installation of S32K SDK ISELED driver 

The S32K SDK ISELED driver BETA 3.9.0 provides the user with necessary API to initialize and drive 

the ISELED LEDs. It provides two options for communication interface, highly effective FlexIO 

interface and standard LPSPI interface. The S32K SDK ISELED driver is not part of standard S32K 

SDK installation and a separate download is required from nxp web. Please follow the instructions to 

proceed: 

1. Visit www.nxp.com/S32K-ISELED web page  

2. Click Get Started Tab and Choose Evaluation Path for Non-AUTOSAR 

 
 

 

3. Download the S32K SDK ISELED driver.  

 

 

4. Alternatively, download link could also be found via www.nxp.com/S32K-ISELED Documents 

and Software Tab. 

http://www.nxp.com/S32K-ISELED
http://nww.preview.nxp.com/document/guide/get-started-with-the-s32k-iseled:GS-S32K-ISELED
http://www.nxp.com/S32K-ISELED
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5. To proceed with the download, the user needs to be logged-in using the user account. In case of 

new user, please proceed with the Register Now option prior logging into the NXP web page. 

 
 

6. Select Automotive SW – Middleware for General Purpose and Integrated Solutions 
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7. Select Automotive SW – ISELED Software 

 
 

8. Select the SW32K1-ISELED-RTM-3.0.0 or newer package.  
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9. Accept the Software Terms and Conditions 

 

10. Download the SCR, Release notes and installation package by selecting the packages 
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11. Generate the license file for the S32K SDK ISELED driver by selecting the License Keys tab. 
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12. Store the license file on your computer. Use this license file during the installation of the NXP 

S32K ISELED Driver. Important: the S32SDK_S32K1xx_RTM_3.0.0 installation directory 

must be selected for the NXP S32K ISELED Driver installation.  
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13. Run the ISELED Driver installer and click “Next” 

 
 

14. Accept the terms of the License Agreement and continue 
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15. Select the license file that was saved previously 

 

16. If the license expires, please contact gpis.software@nxp.com or your NXP sales representative 

and ask for an Activation Code to register the software 

17. Select the components for the installation 

 
 
 

 
 

mailto:gpis.software@nxp.com
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18. Select the installation path. Make sure that the installation path is the same as the S32K SDK 

BETA 3.9.0 installation folder 

 
 

19. Finally click Install to start the setup 
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5. Troubleshooting  

To verify the ISELED Driver installation please follow the next steps: 

1. Start the S32 Design studio and select New S32DS Project from Example in File menu. 

 

 
 

2. If the description of the ISELED Driver example application states that the example is a 

placeholder, it means that the installation path for the ISELED Driver did not match the S32K 

SDK BETA 3.9.0 installation folder. Please see step 3.16. 
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3. Another way to verify the ISELED Driver installation is to check if the ISELED libraries are 

present in the S32K SDK BETA 3.9.0 installation folder 

 

4. In the case that the S32DesignStudio - 

http://www.nxp.com/lgfiles/updates/Eclipse/S32DS_ARM_2018.R1/updatesite is not 

reachable, the SDK can be manually installed. 

5. Download the update package from Updated/Patches (for ADM S32DS - 

https://www.nxp.com/support/developer-resources/run-time-software/s32-design-studio-
ide/s32-design-studio-ide-for-arm-based-mcus:S32DS-ARM?&tab=Design_Tools_Tab 

http://www.nxp.com/lgfiles/updates/Eclipse/S32DS_ARM_2018.R1/updatesite
https://www.nxp.com/support/developer-resources/run-time-software/s32-design-studio-ide/s32-design-studio-ide-for-arm-based-mcus:S32DS-ARM?&tab=Design_Tools_Tab
https://www.nxp.com/support/developer-resources/run-time-software/s32-design-studio-ide/s32-design-studio-ide-for-arm-based-mcus:S32DS-ARM?&tab=Design_Tools_Tab
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6. In Design Studio click on Help -> Install new software and choose Add -> Archive 

 
 

7. Select the previously downloaded update ZIP file and continue with the Next button 
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6. Starting from S32K SDK ISELED example application 

The S32K SDK ISELED driver is provided with the example application. The example application uses 

FreeMASTER SW component from NXP, used for data visualization and operation of project flow. In 

case the FreeMASTER SW component is not installed on your computer, please visit the  

www.nxp.com/freemaster website to download the installation package of the FreeMASTER 

component. 

For a detailed description of the ISELED Driver example application, please refer to the 

ISELED_UserGuide document that can be found in the installation path under the “doc” folder.  

To start the user application based on this example, please follow these instructions: 

1. Start the S32 Design studio and select New S32DS Project from Example in File menu. 

 
 

2. Select the iseled_freemaster_s32k144 example application from the S32K144 examples list. 

file:///C:/work/MCUs/Kinetis_KFA/Other_Mixed_Signal_Parts/Inova/www.nxp.com/freemaster
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3. In case the pop-up window is displayed, select the SDK_S32K1xx_15 components repository. 
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4. Generate the Processor Expert Code by selecting the option in Project menu and wait for the 

code generation to be completed before continuing. 
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5. Build the project by selecting the build command from the menu bar and selecting the 

Debug_FLASH option. 

 

6. Choose the debugging option by selecting Run menu and Debug Configuration item. Here you 

can select the Debug interface option. 
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For more details about the S32K SDK ISELED driver, please open the driver documentation, stored in 

the installation folder. 

For a detailed description of the ISELED Driver example application please read the 

ISELED_UserGuide document that can be found in the installation path under the “doc” folder. 

NOTE 

The S32K SDK ISELED example project is using FreeMASTER SW 

component from NXP, used for data visualization and operation of project 

flow. In case the FreeMASTER SW component is not installed on user 

computer, please visit the www.nxp.com/freemaster to download the 

installation of the FreeMASTER component.

https://www.nxp.com/support/developer-resources/software-development-tools/freemaster-run-time-debugging-tool:FREEMASTER?&tid=vanFREEMASTER
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